La energía solar no es una energía alternativa: es la energía.
Hermann Scheer

Página 3 de 8 PrimerPrimer ... 234 ... ÚltimoÚltimo
Resultados 51 al 75 de 199
  1. #51
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por briko Ver mensaje
    Creo que tu mismo has dado la razon: Has puesto demasiada agua en algunos vasos. Y la solucion es la adecuada
    Ojalá tuvieras razón!
    No lo creo, porque en su día puse la misma cantidad de agua en todas las células. Si ahora las "malas" tenían el nivel demasiado alto, temo que es porque no estaban con la densidad alta al rellenar agua (no lo controlé).
    Me gustaría que tuvieses razón, pero temo que el problema es otro ...

  2. #52
    jmargaix está desconectado Forero
    Fecha de ingreso
    ago 2013
    Ubicación
    massalfassar
    Mensajes
    561

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Hola,
    a mi creo que me pasa lo mismo, tenia unas buenas densidades y las rellene porque estaban algo bajas (eso creía, cubria las placas y les puse 2 litros para las 4 baterias) y ahora no me llegan a la densidad que tenían antes (después de una semana), antes las peores estaban sobre 129 y ahora están e 126.
    Así que pido vuestro consejo por si me toca hacer lo mismo que 'el_cobarde' , es decir sacar electrolito, tengo baterías de tracción ACL de 12V y 150A, cual es el nivel adecuado?
    Mirando por el tapón, las baterías tienen una barra , yo diría que cuadrada de 6 o 7 mm que recorre el lateral, que puede estar a 1 cm de las placas y a 2-3 cm del tapón, pues hasta donde debe de llegar el electrolito ?? Debe cubrir la barra o ligeramente por encima de las placas.
    Yo diría que de nuevas cubría la barra (pero no estoy seguro) y tenia densidades de 129. Tengo un mar de dudas.
    Gracias por vuestros comentarios.
    Saludos.

  3. #53
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por jmargaix Ver mensaje
    ... hasta donde debe de llegar el electrolito ?? Debe cubrir la barra o ligeramente por encima de las placas?
    No soy experto en baterías, pero con lo que he aprendido en los últimos meses, me atrevo a contestar:
    Con la batería cargada a tope (SOC>95%), el nivel del electrolito deberia estar ligeramente por encima de la barra que dices.
    Con la batería totalmente descargada (SOC<20%), el electrolito todavía debe cubrir bien las placas.
    Diría que el nivel ideal está en medio entre barra y tapón.

    Pero también creo que el nivel del electrolito no es tan crucial. Mientras estén las placas siempre cubiertas, todo bien.
    No creo que en mi caso la diferencia de densidad se deba a más o menos agua.

  4. #54
    jmargaix está desconectado Forero
    Fecha de ingreso
    ago 2013
    Ubicación
    massalfassar
    Mensajes
    561

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Hola,
    muchas gracias por tus comentarios.
    Saludos.

  5. #55
    el_cobarde Invitado

    Predeterminado Ecualización: La intensidad de carga no baja ??

    Cita Iniciado por el_cobarde Ver mensaje
    Ayer tuve el tiempo de hacer una ecualización cortita, a 63V durante hora y media. Todo fue bien y la densidad en las "células malas" subió bastante, hasta 1.21g/ml. Las "células buenas" estaban en 1.25g/ml.
    Ayer hice una ecualización más completa: 3 horas, siempre a 63.5V. Las densidad subió a 1.22g/ml en las 6 "células malas" y a 1.25g/ml en las 18 células restantes. Parece que no va a subir más, por mucha ecu que haga ...

    Lo que llamo "las 6 células malas" son las de las dos monoblock (Trojan T-105) que están junto a la pared exterior y de las que salen los cables pos y neg que van al regulador e inversor. No sé que les pasa ...

    Hay otra cosa que no entiendo. A ver si me echáis una mano:
    Empiezo la ecu con las baterías cargadas a tope. Antes de tener "vasos malos", al principio de la ecu medía unos 25A intensidad de carga, que iba bajando poco a poco, hasta llegar a unos 3-5A al finalizar la ecu.
    Ahora no es así!! Empiezo con 25A y se mantienen hasta finalizar la ecu! A las 3 horas tenía los mismos 25A!
    Algo va mal! Alguien puede decirme lo que está pasando? Puedo hacer algo para arreglarlo?

  6. #56
    Avatar de Hlebtomane
    Hlebtomane está desconectado Forero
    Fecha de ingreso
    mar 2007
    Ubicación
    Valencia
    Mensajes
    4.541

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    25 A en ecualización es mucho para estas baterías; limita la intensidad a unos 10 A y déjalas cargar hasta que lleguen a los 63,5 V de esta manera. Entonces las mantienes unas hora más a esta tensión mientras la intensidad de carga vaya disminuyendo.

    Eso sí, evita que se pasen mucho de los 30ºC. A las malas las dejas descansar un día y vuelves el día siguiente.
    Biblioteca básica de energía solar
    Descubre la fotovoltaica jugando y aprende de forma intuitiva con nuestros esquemas interactivos: Esquemas interactivos (requiere flash)

  7. #57
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por Hlebtomane Ver mensaje
    25 A en ecualización es mucho para estas baterías ...
    Gracias, Hlebtomane.
    Había leido en Internet que la intensidad de carga en ecualización no debe ser demasiado alta. Pero los límites recomendados varían entre un 5% hasta un 15% de la capacidad C10 (10A hasta 30A para 200Ah). Parece que no hay unaminidad de opiniones.

    Seguiré tu recomendación, Hlebtomane. Entiendo que menos intensidad de carga castiga menos a las baterías. Efectivamente, la temperatura de mis baterías subió a unos 40-45 grados (sensación al tocarlas).
    Pero realmente crees que una ecu con 10A y muchas horas a 63.5V hará subir la densidad en los vasos malos?
    No tendría que haber subido igual con la ecu de 25A durante 3 horas a 63.5V? ...

  8. #58
    Avatar de Hlebtomane
    Hlebtomane está desconectado Forero
    Fecha de ingreso
    mar 2007
    Ubicación
    Valencia
    Mensajes
    4.541

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por el_cobarde Ver mensaje
    Pero realmente crees que una ecu con 10A y muchas horas a 63.5V hará subir la densidad en los vasos malos? No tendría que haber subido igual con la ecu de 25A durante 3 horas a 63.5V? ...
    Para recuperar los vasos hace falta más tiempo, créeme. Mejor dejas unos días sin uso tu sistema hasta tener los vasos recuperados. Cuando recuperan baterías de forma profesional, lo hacen con intensidad muy baja (un C100 me parece) durante varios días con tensión abierta. Con demasiada intensidad corres peligro de perder material activo. Disolver los cristales de sulfato requiere su tiempo (cuanto más grandes son los cristales, menos superficie específica tienen para la reacción y más tardan en disolverse).

    Para el futuro, ya cuando se te va sólo 0,02 kg/l un vaso, ya tienes que hacer la EQ para evitar que pasa lo que ha pasado.
    Biblioteca básica de energía solar
    Descubre la fotovoltaica jugando y aprende de forma intuitiva con nuestros esquemas interactivos: Esquemas interactivos (requiere flash)

  9. #59
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por Hlebtomane Ver mensaje
    Para recuperar los vasos hace falta más tiempo, créeme ...
    Muchas gracias, Hlebtomane. Pondré una intensidad de carga de 10A a 64V para muchas horas.
    En el futuro haré las ecualizaciones más "suaves" y más a menudo ...

    El hecho de que no bajaba la intensidad de carga (se mantenía en 25A) se debe a que hay cristales de sulfato sin resolver - lo que impide que suba la resistencia interna ?
    Puedo ecualizar con 10A iniciales hasta que la intensidad haya bajado a 3A, digamos? Aunque sean muchas horas?

  10. #60
    Avatar de Hlebtomane
    Hlebtomane está desconectado Forero
    Fecha de ingreso
    mar 2007
    Ubicación
    Valencia
    Mensajes
    4.541

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por el_cobarde Ver mensaje
    El hecho de que no bajaba la intensidad de carga (se mantenía en 25A) se debe a que hay cristales de sulfato sin resolver - lo que impide que suba la resistencia interna ?
    A ver, tengo que consultar mi bola de cristal...
    A lo mejor lo de no disminuir la intensidad fue debido a que se aumentó la temperatura con lo cual es como si hubieras subido la tensión de ecualización. 63,5 V a 40-45ºC es una barbaridad. ¿No te compensa la tensión de ecualización con la temperatura de la batería (por haber puesto sonda de temperatura)?

    También tienes que tener en cuenta que de 45ºC a 20ºC la densidad aumenta casi dos centésimas.

    Cita Iniciado por el_cobarde Ver mensaje
    Puedo ecualizar con 10A iniciales hasta que la intensidad haya bajado a 3A, digamos? Aunque sean muchas horas?
    Sí, pero procura que no se caliente tanto la batería; no permitas que suba de 35ºC.
    Biblioteca básica de energía solar
    Descubre la fotovoltaica jugando y aprende de forma intuitiva con nuestros esquemas interactivos: Esquemas interactivos (requiere flash)

  11. #61
    el_cobarde Invitado

    Predeterminado Re: Batería: Los &quot;vasos finales&quot; no tienen densidad !?

    Cita Iniciado por Hlebtomane Ver mensaje
    A lo mejor lo de no disminuir la intensidad fue debido a que se aumentó la temperatura con lo cual es como si hubieras subido la tensión de ecualización. 63,5 V a 40-45ºC es una barbaridad. ¿No te compensa la tensión de ecualización con la temperatura de la batería (por haber puesto sonda de temperatura)?
    Sí tengo sonda de temperatura y sí me compensa, en absorción y flotación. Pero posiblemente no me compense en ecualización, manteniendo la tensión en el valor configurado (63.5V), independiente de la temperatura.
    Pero tengo que rectificar un detalle: La temperatura que "medí" con la mano, parece que no fue tan alta. Comparando mi "sensor mano" con el NTC, más bien eran menos de 40 grados, algo como 35 grados.

    - - - - - - - - - - - - - - - - - - -

    Cita Iniciado por el_cobarde Ver mensaje
    Pondré una intensidad de carga de 10A a 64V para muchas horas ...
    Me he puesto manos a la obra al instante y estoy ecualizando "con 10A a 64V".
    Pero surge un problema: A pesar de que la batería está al SOC 100%, con 10A la tensión no sube a 64V; se queda en unos 62V. Para subir a 64V, necesito una intensidad de carga de >20A.
    Ahora lo he dejado en 15A, con lo que la tensión me sube a 63V. Si más tarde llegara a los 64V, reduciré la intensidad a 10A.

    @Hlebtomane: Te parece razonable, lo que estoy haciendo?

  12. #62
    Avatar de Hlebtomane
    Hlebtomane está desconectado Forero
    Fecha de ingreso
    mar 2007
    Ubicación
    Valencia
    Mensajes
    4.541

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    No seas ansias, déjalo mejor en 10 A y te esperas a que suba la tensión a 64 V; a lo mejor no lo hace hoy, tal vez ni mañana, pero llegará el día que sí. Total con 15 A te sube más rápido, pero también se calienta más la batería con lo cual a lo mejor tienes que frenar el proceso y al final tarda lo mismo, pero tienes que estar más pendiente y encima se te daña más la batería.

    No entiendo por qué el regulador no compensa tensión por temperatura en la etapa de ecualización. Los 64 V ya pueden ser bastante dañinos con temperaturas altas de batería, pues 64 V a 35ºC equivalen a 65,8 V a 20ºC, eso también lo tienes que tener en cuenta.
    Biblioteca básica de energía solar
    Descubre la fotovoltaica jugando y aprende de forma intuitiva con nuestros esquemas interactivos: Esquemas interactivos (requiere flash)

  13. #63
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por Hlebtomane Ver mensaje
    No seas ansias, déjalo mejor en 10 A y te esperas a que suba la tensión a 64 V; a lo mejor no lo hace hoy, tal vez ni mañana ...
    De acuerdo, gracias. Dejaré la intensidad en 10A y tendré paciencia ...


    Cita Iniciado por Hlebtomane Ver mensaje
    No entiendo por qué el regulador no compensa tensión por temperatura en la etapa de ecualización.
    Pues parece que sí compensa la tensión! ...
    Acabo de medir la tensión de batería con un polímetro y me marca 62.1V, mientras la pantallita del regulador me marca 63V. Y las baterías están a 28C. Parece que el regulador cumple y por allí no hay problemas.

  14. #64
    Avatar de Hlebtomane
    Hlebtomane está desconectado Forero
    Fecha de ingreso
    mar 2007
    Ubicación
    Valencia
    Mensajes
    4.541

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por el_cobarde Ver mensaje
    Pues parece que sí compensa la tensión! ...
    Acabo de medir la tensión de batería con un polímetro y me marca 62.1V, mientras la pantallita del regulador me marca 63V. Y las baterías están a 28C. Parece que el regulador cumple y por allí no hay problemas.
    Hmmm, puede ser que así sea, pero sería una forma muy rara de compensar la tensión, normalmente la compensación se hace sobre el objetivo de tensión y no sobre la tensión medida. No va a ser que simplemente mide mal la tensión (que es algo que pasa incluso en los Outback y Midnite, pero dan la posibilidad de rectificar el error de medición configurando un "offset").
    Biblioteca básica de energía solar
    Descubre la fotovoltaica jugando y aprende de forma intuitiva con nuestros esquemas interactivos: Esquemas interactivos (requiere flash)

  15. #65
    Invitado Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por el_cobarde Ver mensaje
    ...
    Acabo de medir la tensión de batería con un polímetro y me marca 62.1V, mientras la pantallita del regulador me marca 63V.....
    Has comprobado la tensión en bornes de la batería o justo en la salida del regulador ? Podría ser que tuvieras una pequeña caída de tensión en el cable o en la conexión de los terminales del regulador.
    Las fuentes de alimentación de 'laboratorio' tienen 4 bornes, 2 para la potencia y 2 más para el sensor de tensión para monitorizar y controlar exactamente la tensión en la 'carga', aunque esté a 4 metros.
    Eso sería lo ideal también para un regulador de carga, pero entiendo que también es un lío y un engorro.

    Saludos

  16. #66
    el_cobarde Invitado

    Predeterminado Re: Batería: Los &amp;amp;quot;vasos finales&amp;amp;quot; no tienen densidad !?

    Cita Iniciado por oxid Ver mensaje
    Has comprobado la tensión en bornes de la batería o justo en la salida del regulador ?
    He medido en los bornes de la batería, para esquivar problemas debidos a caida de tensión.


    Cita Iniciado por oxid Ver mensaje
    Las fuentes de alimentación de 'laboratorio' tienen 4 bornes, 2 para la potencia y 2 más para el sensor de tensión para monitorizar y controlar exactamente la tensión en la 'carga' ...
    Mi regulador, el SunStar SS-50C de Rich Electric, tiene un sensor de tensión tal como dices, independiente de los cables de potencia. Se conecta directamente en el borne positivo de la batería. Lo que no tiene, es cable negativo independiente.


    - - - - - - - - - - - - - - - - - - -


    Cita Iniciado por Hlebtomane Ver mensaje
    No seas ansias, déjalo mejor en 10 A y te esperas a que suba la tensión a 64 V; a lo mejor no lo hace hoy, tal vez ni mañana ...
    Me has aconsejado bien, Hlebtomane. Gracias ...
    Hoy he hecho 6 horas de ecualización, tal como decías: Con 10A a 64V. Bueno, con 10A, la tensión solo subía a 62V, pero he cumplido con lo que me decías: No tocar nada. A partir de las 14:00h, el sol se iba escondiendo tras una neblilla, y la intensidad de carga se iba reduciendo (por falta de irradiación) hasta 5A al finalizar la ecu, a una tensión de 58.5V.
    La temperatura de las baterías nunca ha subido a más de 31C (medido con la resistencia NTC).
    Es decir, la ecu ha sido aún más suave de lo previsto.

    Pero la densidad ha mejorado! Ahora está entre 1.26 y 1.27 g/ml en todos los vasos! Puedo decir tranquilamente, que la densidad en los "vasos malos" se ha recuperado.

    El próximo día con sol seguiré ecualizando, a ver si al final se reduce la intensidad de carga no por falta de sol, sino por aumento de la "contratensión" que genera la batería. Entonces estaré satisfecho.

  17. #67
    Invitado Invitado

    Predeterminado Re: Batería: Los &amp;amp;quot;vasos finales&amp;amp;quot; no tienen densidad !?

    Cita Iniciado por el_cobarde Ver mensaje
    He medido en los bornes de la batería, para esquivar problemas debidos a caida de tensión.



    Mi regulador, el SunStar SS-50C de Rich Electric, tiene un sensor de tensión tal como dices, independiente de los cables de potencia. Se conecta directamente en el borne positivo de la batería. Lo que no tiene, es cable negativo independiente.
    Bueno, no se si me he explicado bien, de lo que se trata es de medir con el polímetro en bornes del regulador y verificar que lo que marca ( el regulador) es correcto, aunque en tu caso la 'supuesta' caída de tensión sólo se produciría en el cable negativo puesto que es común.

  18. #68
    el_cobarde Invitado

    Predeterminado Re: Batería: Los &amp;amp;amp;quot;vasos finales&amp;amp;amp;quot; no tienen densidad !?

    Cita Iniciado por oxid Ver mensaje
    ... de lo que se trata es de medir con el polímetro en bornes del regulador y verificar que lo que marca ( el regulador) es correcto ...
    Ahora entiendo a lo que te refieres. Acabo de subir a donde el regulador y he medido con el polímetro en la entrada de batería del regulador. Me daba 49.8V, mientras el regulador marcaba 50.4V, o sea, 0.6V más en el regulador.
    Antes, cuando había medido con el polímetro directamente en los bornes de la batería, me daba 62.1V el polímetro y 63.0V el regulador. Prácticamente la misma diferencia que ahora.
    Es que la temperatura de la batería está muy cerca de los 25C estandardizados. Si no enfrío o caliento la batería, no puedo averiguar, si el regulador hace compensación de tensión por temperatura.

    Ahora que viene el verano, ya lo averiguaré en otro momento, cuando la batería esté más caliente ...
    Lo importante del momento me parece ser, que la densidad de los "vasos malos" realmente ha mejorado.

  19. #69
    Avatar de Hlebtomane
    Hlebtomane está desconectado Forero
    Fecha de ingreso
    mar 2007
    Ubicación
    Valencia
    Mensajes
    4.541

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Me alegro que al final se han recuperado bastante bien en poco tiempo. Eso sí, queda el misterio de qué ha provocado la caída de densidad en algunos vasos...
    Biblioteca básica de energía solar
    Descubre la fotovoltaica jugando y aprende de forma intuitiva con nuestros esquemas interactivos: Esquemas interactivos (requiere flash)

  20. #70
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por Hlebtomane Ver mensaje
    Me alegro que al final se han recuperado bastante bien en poco tiempo.
    Si, gracias a tu ayuda
    Hoy llueve, pero cuando haga sol seguiré ecualizando, a ver sí mejoran aún más los vasos ...


    Cita Iniciado por Hlebtomane Ver mensaje
    Eso sí, queda el misterio de qué ha provocado la caída de densidad en algunos vasos...
    Si, es un misterio sin resolver. Tendré que fijarme mejor y ecualizar, cuando haya >0.2g/ml de diferencia de densidad.
    Y tampoco estará mal, cambiar las baterías de posición cada 6 meses, más o menos.

  21. #71
    Jiro está desconectado Forero
    Fecha de ingreso
    feb 2009
    Ubicación
    xxx
    Mensajes
    1.732

    Predeterminado Re: Batería: Los &quot;vasos finales&quot; no tienen densidad !?

    Cita Iniciado por el_cobarde Ver mensaje
    Si, gracias a tu ayuda
    Hoy llueve, pero cuando haga sol seguiré ecualizando, a ver sí mejoran aún más los vasos ...



    Si, es un misterio sin resolver. Tendré que fijarme mejor y ecualizar, cuando haya >0.2g/ml de diferencia de densidad.
    Y tampoco estará mal, cambiar las baterías de posición cada 6 meses, más o menos.
    Yo después de leer tu problema, dejé algo largos los cables por si acaso. Es mucho mas fácil cambiar los cables de sitio que las baterías que pesan mogollón.

    - - - - - - - - - - - - - - - - - - -

    Quizá debas poner la absorción a mas V o mas larga para que no llegue a ocurrirte esto.

    En mis monoblock, una vez puestas en su densidad, no he tenido que volver a equalizarlas y estan a tope 1.30 e incluso alguna 1.305

  22. #72
    Jiro está desconectado Forero
    Fecha de ingreso
    feb 2009
    Ubicación
    xxx
    Mensajes
    1.732

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?


  23. #73
    el_cobarde Invitado

    Predeterminado Re: Batería: Los &quot;vasos finales&quot; no tienen densidad !?

    Cita Iniciado por Jiro Ver mensaje
    Yo después de leer tu problema, dejé algo largos los cables por si acaso. Es mucho mas fácil cambiar los cables de sitio que las baterías que pesan mogollón.
    Esto sería una solución muy buena, si los vasos "malos" serían los de donde salen los cables pos y neg al regulador / inversor. Al principio me parecía ser esto, pero ya no estoy nada seguro. Los vasos "malos" no eran solo estos dos; eran los 6 vasos de las dos monoblock tocando la pared que da al exterior. Parece que la cercanía a la pared influye de alguna forma - acoplamiento capacitivo ??
    Siendo asi, no bastaría conectar los cables de salida a otros vasos, habría que mover las baterías.
    Realmente es un misterio, lo que ha pasado. Veremos si con el tiempo se aclara ...

    Cita Iniciado por Jiro Ver mensaje
    Quizá debas poner la absorción a mas V o mas larga para que no llegue a ocurrirte esto.
    Más tensión no puedo, con 58.5V ya estoy muy cerca de los 60V donde corta el híbrido. Más tiempo sí puedo. Lo intentaré.
    Todo indica que tengo que eliminar un elemento de una monoblock, para tener solo 23 elementos / vasos. Entonces hasta podría hacer una ecualización automatizada cada 2 semanas, por ejemplo.


    Cita Iniciado por Jiro Ver mensaje
    En mis monoblock, una vez puestas en su densidad, no he tenido que volver a equalizarlas y estan a tope 1.30 e incluso alguna 1.305
    Enhorabuena! Que envidia!

  24. #74
    Jiro está desconectado Forero
    Fecha de ingreso
    feb 2009
    Ubicación
    xxx
    Mensajes
    1.732

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Ahora estamos a ver si encontramos el punto exacto también en los vasos grandes, aún estoy en ello.

  25. #75
    el_cobarde Invitado

    Predeterminado Re: Batería: Los "vasos finales" no tienen densidad !?

    Cita Iniciado por Jiro Ver mensaje
    Ahora estamos a ver si encontramos el punto exacto también en los vasos grandes, aún estoy en ello.
    Cómo buscas "el punto exacto" ?

Página 3 de 8 PrimerPrimer ... 234 ... ÚltimoÚltimo

© 2002-2021 Solarweb.net



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46