La energía solar no es una energía alternativa: es la energía.
Hermann Scheer

Página 1 de 3 12 ... ÚltimoÚltimo
Resultados 1 al 20 de 52
  1. #1
    albertin_omt está desconectado Forero
    Fecha de ingreso
    sep 2009
    Ubicación
    Madrid
    Mensajes
    130

    Predeterminado Problema para alimentar termo en CC: reles

    Hola a todos.
    Ya tengo montados 2KWp en placas, que dan 240V en CC. Lo he conectado directamente en CC a un termo electrico de 100 litros y 1.500w pero el primer día se han quedado pegados los contactos del termostato que trae el termo.
    He probado a instalar un relé de los gordos (de tres circuitos) que actua cuando el termostato llega al 70º, pero cuando abre el circuito en el relé se crea un arco voltaico (las chapas están a medio milímetro) y como lo deje unos segundo se quema también. Creo que es demasiada potencia y tension para cualquier relé de chapas.
    La pregunta es si puedo usar otro relé, por ejemplo de estado sólido, como los Crydom,
    Compre Relés de Estado Sólido SSR,serie LS,SCR,cruce cero,12A/280V Crydom LS240D12 en RS Online y lo recibirá en 24/48 horas.
    que soporta salidas de 12A y 280v, pero son cargas en corriente alterna: ¿puedo usar uno de esos pero cargas en corriente contínua?. Funcionaría igual un Crydom para CC?
    Saludos.

  2. #2
    carlos6025 está desconectado Forero
    Fecha de ingreso
    ago 2010
    Ubicación
    alicante
    Mensajes
    5.316
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Primero de todo, ¿cuantas placas has puesto, de cuantas células y si están todas en serie?

    Tienes que buscar rele de CC y de 400VDC, de 10 Amp. como mínimo. El problema es la señal de control, de donde la sacas

    De todas formas, ¿Como conectaste el contactor, con todos los contactos en paralelo? Hay que colocarlos en serie, para que el arco se "reparta" entre los contactos, y así, que pueda desaparecer.

  3. #3
    albertin_omt está desconectado Forero
    Fecha de ingreso
    sep 2009
    Ubicación
    Madrid
    Mensajes
    130

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Hola.... pues no se me había ocurrido colocarlos en serie. Tienes razón, de esta manera es imposible que haga arco ya que la separación sería muy grande. Creo que con un par de reles valdría.
    He puesto 8 placas de 255w cada una y unos 30v, todas en serie: 204Wp y 240v
    Este viernes pruebo la configuración de los relés en serie y os cuento. Os dejo la foto del rele.
    La señal de control (la que opera el relé) la saco del termostato.

    Problema para alimentar termo en CC: reles-img_6289.jpg
    He puesto como proteciones un magnetotermico de 16A como elemento de corte y un fusible de 10A, está bien?. Os dejo la foto.
    El cable es de 10mm2 y unos 15m de largo, está bien para esa potencia?
    Gracias y saludos.

    Problema para alimentar termo en CC: reles-img_6140.jpg
    Problema para alimentar termo en CC: reles-img_6433.jpg

  4. #4
    carlos6025 está desconectado Forero
    Fecha de ingreso
    ago 2010
    Ubicación
    alicante
    Mensajes
    5.316
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por albertin_omt Ver mensaje
    Hola.... pues no se me había ocurrido colocarlos en serie. Tienes razón, de esta manera es imposible que haga arco ya que la separación sería muy grande. Creo que con un par de reles valdría.
    Primero prueba con 1 solo rele, pero con todos sus contactos en serie. Si ves que aún así se queman, pones otro rele, que al final serán 6 contactos en serie.
    De todas formas, el relé de la foto me parece un poco pequeño. Tienes que ver que sus contactos sean para 230VAC como mínimo.

    Cita Iniciado por albertin_omt Ver mensaje
    He puesto 8 placas de 255w cada una y unos 30v, todas en serie: 204Wp y 240v
    Quizás trabaje un poco forzado la resistencia del termo. ¿Has comprobado la tensión que le llega a la resistencia con sol a medio-día? diría que va a pasar de 250 voltios.

    Cita Iniciado por albertin_omt Ver mensaje
    He puesto como proteciones un magnetotermico de 16A como elemento de corte y un fusible de 10A, está bien?. Os dejo la foto.
    El cable es de 10mm2 y unos 15m de largo, está bien para esa potencia?
    Gracias y saludos.
    Al magneto le puede pasar lo mismo que al relé, que se quemen sus contactos. Yo pondría uno de 16A, pero tetrapolar, con 2 contactos en serie para cada polo. Y aún así...

    De cable vas más que sobrado.

  5. #5
    Fecha de ingreso
    abr 2012
    Mensajes
    1.179
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Acabo de tener un problema similar con un contactor de 24v ca. Simplemente se achicharra su bobina si lo alimentas con un maximo de 28vcc. Lo he solucionado colocando una resistencia de 12 vatios y 15 ohmios en serie con ella (tengo un monton de contactores de ese tipo y no pienso tirarlos para comprar otros de cc)

    Para cuantos amperios son los contactos de potencia del contactor que has puesto?

  6. #6
    pauneus está desconectado Forero Junior
    Fecha de ingreso
    dic 2010
    Ubicación
    gandia
    Mensajes
    21

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Te sobra tension, con 150v cc tienes suficiente.
    Te lo digo por experiencia.

  7. #7
    isidoro111 está desconectado Forero
    Fecha de ingreso
    ago 2007
    Ubicación
    Ciudad Real
    Mensajes
    340

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Hola albertin_omt, coincido con pauneus en lo de los 150v.

    240v en cc son mucha tela. He hecho experiencias con 150v cc (5 placas) y también salta arco en el termostato. Coincido con los anteriores que te recomendaron el interrptor de cuatro polos y ponerlo en "serie".

    También otra sugerencia si dejas como definitivo el invento, es el tema de la protección frente a derivaciones. Pon una toma de tierra de categoría. Yo tengo el experimento con un acumulador de calor (los de las piedras), con el termo no me atrevo por la falta de protecciones.

    saludos.

  8. #8
    Lugh está desconectado Forero
    Fecha de ingreso
    oct 2005
    Ubicación
    Valladolid
    Mensajes
    616

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Pues no estoy de acuerdo con que sea suficiente con 150V, todo un desperdicio.

    A ver, cuando alimentamos directamente una resistencia con un sistema fotovoltaico, la tensión de funcionamiento nos la marcará la resistencia.

    Si el fabricante nos dice que es una resistencia de 1500W en CA, pues aproximadamente tendremos una resistencia de R=V^2/P=35,27 Ohmnios (consideremos el coseno de phi=1).

    Lo pongo gráficamente en el pdf adjunto que creo que no dejará lugar a dudas. En el caso de de poner los 8 módulos de albertin_omt en serie (curva roja) aprovechamos al máximo la potencia instalada, pero si ponemos 4 en serie y dos filas en paralelo (curva azul) es como si instalásemos dos módulos en vez de 8.

    Si salta arco habrá que poner protecciones y seleccionar el relé adecuado.

    Para reducir el peligro de contactos indirectos se puede poner a tierra la mitad de la serie, de esta forma reducimos el posible contacto indirecto a solo 120VCC, tensión ya muy poco peligrosa ya que si consideramos la resistencia del cuerpo humano de 2000 Ohmnios, en caso de contacto pasarían por el cuerpo 60 mA, y le intensidad de fibrilación en CC es de 100 mA.
    Archivos adjuntados Archivos adjuntados

  9. #9
    carlos6025 está desconectado Forero
    Fecha de ingreso
    ago 2010
    Ubicación
    alicante
    Mensajes
    5.316
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por Lugh Ver mensaje
    Pues no estoy de acuerdo con que sea suficiente con 150V, todo un desperdicio.

    A ver, cuando alimentamos directamente una resistencia con un sistema fotovoltaico, la tensión de funcionamiento nos la marcará la resistencia.

    Si el fabricante nos dice que es una resistencia de 1500W en CA, pues aproximadamente tendremos una resistencia de R=V^2/P=35,27 Ohmnios (consideremos el coseno de phi=1).

    Lo pongo gráficamente en el pdf adjunto que creo que no dejará lugar a dudas. En el caso de de poner los 8 módulos de albertin_omt en serie (curva roja) aprovechamos al máximo la potencia instalada, pero si ponemos 4 en serie y dos filas en paralelo (curva azul) es como si instalásemos dos módulos en vez de 8.
    Totalmente de acuerdo.

    Ya lo dije en su día y se discutió en un hilo. Para obtener el máximo rendimiento de las placas, la impedancia de las placas en su máximo rendimiento debe ser igual a la impedancia, en este caso resistencia del termo.
    Lo que quiere decir que si el termo tiene una tensión nominal de 230VAC, el nº de placas de 60 células debe ser de 230/30Vmp= 7,6 placas. Como eso no puede ser, entre 8 y 7 es el nº de placas ideal. Pero siempre que la potencia pico sea igual a la del termo. Como en este caso tenemos 255wx8= 2050wp y el termo es de 1500w, yo pondría 7 placas.
    Al ser 7 placas obtenemos 7 x 30 =210vcc. Pero como la potencia sigue siendo superior, 7 x 255 = 1785w frente a 1500w del termo, la tensión de trabajo final va a ser superior a los 210 VCC y va a estar más cerca de los 230 VCC.
    De todas formas, habría que ver en la práctica a cuanto llega la tensión de trabajo con 8 placas.


    Trabajar a 150VCC es como tener la mitad de las placas de adorno. No dudo que también puedan calentar el agua, pero desperdiciando mucha energía.




    Cita Iniciado por Lugh Ver mensaje

    Si salta arco habrá que poner protecciones y seleccionar el relé adecuado.

    Para reducir el peligro de contactos indirectos se puede poner a tierra la mitad de la serie, de esta forma reducimos el posible contacto indirecto a solo 120VCC, tensión ya muy poco peligrosa ya que si consideramos la resistencia del cuerpo humano de 2000 Ohmnios, en caso de contacto pasarían por el cuerpo 60 mA, y le intensidad de fibrilación en CC es de 100 mA.
    Con respecto a la seguridad, si se comunica la resistencia al envolvente de chapa del termo no va a pasar nada. Saltará el magneto si está calibrado a la intensidad ICC de la serie de placas.
    Si se comunica solo con el agua, tampoco se debería notar nada al ducharse, ya que el circuito se cierra con la envolvente metálica el termo y la tubería, siempre que sea metálica y no se rompa en ningún punto la unión con tierra.

    Una solución a este problema de la seguridad, se me ocurre poner un relé bi-estable (teleruptor) entre el termo y tierra. En caso de derivación, cambiaría de estado y des-activaría el relé principal.

  10. #10
    isidoro111 está desconectado Forero
    Fecha de ingreso
    ago 2007
    Ubicación
    Ciudad Real
    Mensajes
    340

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Hola Lugh, muy interesante y convincente tu post. Sólo me ha quedado una duda, como estamos hablando de un termo para ACS, ¿cuál es la resistencia del cuerpo humano mojado por ejemplo mientras toma una ducha?

    Y, ¿si además en el suelo de la bañera tenemos unos deditos de agua? cosa nada inhabitual...

    saludos.

  11. #11
    carlos6025 está desconectado Forero
    Fecha de ingreso
    ago 2010
    Ubicación
    alicante
    Mensajes
    5.316
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Para ser justos, también habría que decir que es perfectamente posible utilizar menos placas y trabajar a menos tensión, siempre y cuando las placas trabajen a su Vmp o muy cerca.

    Para explicarlo mejor:

    Problema para alimentar termo en CC: reles-curva.jpg

    En este caso, podría ser 8 placas de 36 células y de una potencia de unos 80w por placa, aprox. Y trabajarían muy cerca de su punto óptimo.

  12. #12
    isidoro111 está desconectado Forero
    Fecha de ingreso
    ago 2007
    Ubicación
    Ciudad Real
    Mensajes
    340

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por carlos6025 Ver mensaje

    ...
    Con respecto a la seguridad, si se comunica la resistencia al envolvente de chapa del termo no va a pasar nada. Saltará el magneto si está calibrado a la intensidad ICC de la serie de placas.
    Si se comunica solo con el agua, tampoco se debería notar nada al ducharse, ya que el circuito se cierra con la envolvente metálica el termo y la tubería, siempre que sea metálica y no se rompa en ningún punto la unión con tierra.

    ...
    Una pregunta sobre el disparo del magneto, y hablo desde la ignorancia, ¿que magneto pondrías tu? Si estamos hablando de una serie de placas, ¿sería de 8 A? ¿cuándo se dispara un magneto de 8A? ¿cuando pasa una corriente mayor de 8A durante un tiempo? Me parece difícil que se dispare si la corriente encuentra otro camino, las placas no van a dar mas amperios en ese caso ni aunque las cortocircuites (lo que si ocurre con la red de CA). Un magneto NO hace la función de un diferencial, y no conozco los diferenciales de CC.

    La envolvente de los termos suele ser vitrificada o esmaltada. Lo mismo es mejor conductora el agua para cerrar el circuito de una resistencia con una derivación.

    Por último para contestarme a mí mismo, sobre la resistencia el cuerpo humano, depende de la tensión pero a unos 50 v con el cuerpo mojado es de 875 ohmios y con los pies sumergidos en el charquito de la bañera 440 ohmios... Para pensárselo aunque la tierra nos proteja.

  13. #13
    Fecha de ingreso
    abr 2012
    Mensajes
    1.179
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Realmente, hay que intentar que las placas trabajen cerca de su voltaje de potencia pico; hacerlas trabajar fuera de eso es desperdiciarlas. Pero si ya se tienen, pues a ponerlas

    La limitacion en este caso es la intensidad que soportan los contactos de potencia del contactor. Si los que se han puesto no aguantan...pues mas gordos. Arco va a saltar si o si. Y mas aun, en continua. Y sabiendolo, sobredimensionar

  14. #14
    carlos6025 está desconectado Forero
    Fecha de ingreso
    ago 2010
    Ubicación
    alicante
    Mensajes
    5.316
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Si, creo que va a ser imposible encontrar un magneto que no salte a 8 A. pero que salte a 8,2A. Por eso decía lo de poner un relé entre la tierra y la masa del termo.

    Si que hay diferenciales de CC pero valen un egg.

    Aunque sea esmaltada o vitrificada, la superficie tan grande hace que la resistencia sea pequeña. Además, no todo lo que está en contacto con el agua está vitrificado. La misma resistencia o la vaina donde se introduce no lo está.

    Pienso que al final, la resistencia de todo el circuito hidráulico es bastante menor que la del cuerpo humano, y por ahí se va toda la potencia.

  15. #15
    isidoro111 está desconectado Forero
    Fecha de ingreso
    ago 2007
    Ubicación
    Ciudad Real
    Mensajes
    340

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por carlos6025 Ver mensaje
    Si, creo que va a ser imposible encontrar un magneto que no salte a 8 A. pero que salte a 8,2A. Por eso decía lo de poner un relé entre la tierra y la masa del termo.

    Si que hay diferenciales de CC pero valen un egg.

    Aunque sea esmaltada o vitrificada, la superficie tan grande hace que la resistencia sea pequeña. Además, no todo lo que está en contacto con el agua está vitrificado. La misma resistencia o la vaina donde se introduce no lo está.

    Pienso que al final, la resistencia de todo el circuito hidráulico es bastante menor que la del cuerpo humano, y por ahí se va toda la potencia.
    ¿Me sabrías dar marca y modelo o cualquier otra referencia de un diferencial de CC? Yo no lo he encontrado, pero todos son días de aprender...

    Es cierto, tienes razón, la vaina donde está metida la resistencia es metálica y debe estar conectada a tierra, creo que por ahí nos podríamos salvar.

    saludos

  16. #16
    pauneus está desconectado Forero Junior
    Fecha de ingreso
    dic 2010
    Ubicación
    gandia
    Mensajes
    21

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cuando escribo se lo que digo.Tengo un termo de 100 l de agua con una resistencia de 2500w con 5 placas de 72 cel. y de 305 w. cada placa y alimento la resistencia del termo con 150m cc mas o menos, tuve el problema de los reles y lo solucione con un contactor de multiples contactos en serie para repartir la tension (problema solucionado) y os aseguro que calienta el agua mas rapido que alimentandolo a 230 ca.
    Usando un buen contactor no vas a tener problemas, hay incluso que soplan aire para eliminar el arco voltaico.
    Hablo con la experiencia de tenerlo funcionando perfectamente.
    Corto y cierro por mi parte.

  17. #17
    carlos6025 está desconectado Forero
    Fecha de ingreso
    ago 2010
    Ubicación
    alicante
    Mensajes
    5.316
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por pauneus Ver mensaje
    Cuando escribo se lo que digo.Tengo un termo de 100 l de agua con una resistencia de 2500w con 5 placas de 72 cel. y de 305 w. cada placa y alimento la resistencia del termo con 150m cc mas o menos, tuve el problema de los reles y lo solucione con un contactor de multiples contactos en serie para repartir la tension (problema solucionado) y os aseguro que calienta el agua mas rapido que alimentandolo a 230 ca.
    Acabas de inventar la fuente de energía del futuro. Con 5 x 305w= 1525w en placas eras capaz de calentar el agua más rapidamente que con 230VAC y 2500w.

    Lo siento, pero no me lo creo.

    - - - - - - - - - - - - - - - - - - -

    Cita Iniciado por isidoro111 Ver mensaje
    ¿Me sabrías dar marca y modelo o cualquier otra referencia de un diferencial de CC? Yo no lo he encontrado, pero todos son días de aprender...
    Me refería a un vigilante de aislamiento, por eso decía que valen un egg.


    Pensando en el problema de la seguridad, ¿Que os parece un magnetotérmico bipolar de 1A. (si, de 1A. los he visto), de tal forma que por un polo pase la "posible" corriente de defecto a tierra, es decir, colocándolo entre masa y tierra. Y el otro polo sirva para abrir el circuito de control del relé de potencia?.

    Si hay una fuga mayor de 1 A. saltaría y abriría al relé, quedando la resistencia totalmente desconectada de las placas.

  18. #18
    dj_chispas está desconectado Forero
    Fecha de ingreso
    oct 2008
    Ubicación
    Ciudad Real
    Mensajes
    34

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por isidoro111 Ver mensaje
    ¿Me sabrías dar marca y modelo o cualquier otra referencia de un diferencial de CC? Yo no lo he encontrado, pero todos son días de aprender...

    Si que hay diferenciales de cc son los llamados clase B schneider electric (merlin gerin) los tiene pero cualquier marca de prestigio seguro que tambien, pero como an dicho por ahi valen un huevo y parte del otro sin ir mas lejos el mas barato sin decuento ni na unos 1600€

    Saludos.

    - - - - - - - - - - - - - - - - - - -

    Otra cosa que se me viene a la cabeza en cuanto a seguridad, si estamos alimentando la resistencia directo de las placas en cc si no conectas en ninguna parte antes del termo el positivo o negativo a tierra daria igual que se derivase la resistencia la corriente no tendria ningun sitio por donde salir.

    Saludos.

  19. #19
    Fecha de ingreso
    abr 2012
    Mensajes
    1.179
    Entradas de blog
    2

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por carlos6025 Ver mensaje
    Acabas de inventar la fuente de energía del futuro. Con 5 x 305w= 1525w en placas eras capaz de calentar el agua más rapidamente que con 230VAC y 2500w.

    Lo siento, pero no me lo creo.
    Aparte de que 5 placas de 72 celulas en serie no pasan de 150v

    Yo tampoco me lo creo

    - - - - - - - - - - - - - - - - - - -

    Cita Iniciado por carlos6025 Ver mensaje

    Pensando en el problema de la seguridad, ¿Que os parece un magnetotérmico bipolar de 1A. (si, de 1A. los he visto), de tal forma que por un polo pase la "posible" corriente de defecto a tierra, es decir, colocándolo entre masa y tierra. Y el otro polo sirva para abrir el circuito de control del relé de potencia?.

    Si hay una fuga mayor de 1 A. saltaría y abriría al relé, quedando la resistencia totalmente desconectada de las placas.
    Podria funcionar, si no se pone mas que esa toma a tierra. Habria que probarlo y ver que pasa

  20. #20
    Lugh está desconectado Forero
    Fecha de ingreso
    oct 2005
    Ubicación
    Valladolid
    Mensajes
    616

    Predeterminado Re: Problema para alimentar termo en CC: reles

    Cita Iniciado por isidoro111 Ver mensaje
    Una pregunta sobre el disparo del magneto, y hablo desde la ignorancia, ¿que magneto pondrías tu? Si estamos hablando de una serie de placas, ¿sería de 8 A? ¿cuándo se dispara un magneto de 8A? ¿cuando pasa una corriente mayor de 8A durante un tiempo? Me parece difícil que se dispare si la corriente encuentra otro camino, las placas no van a dar mas amperios en ese caso ni aunque las cortocircuites (lo que si ocurre con la red de CA). Un magneto NO hace la función de un diferencial, y no conozco los diferenciales de CC.

    La envolvente de los termos suele ser vitrificada o esmaltada. Lo mismo es mejor conductora el agua para cerrar el circuito de una resistencia con una derivación.

    Por último para contestarme a mí mismo, sobre la resistencia el cuerpo humano, depende de la tensión pero a unos 50 v con el cuerpo mojado es de 875 ohmios y con los pies sumergidos en el charquito de la bañera 440 ohmios... Para pensárselo aunque la tierra nos proteja.
    Un magneto muy justo saltará al poco tiempo por estrés térmico, en fotovoltaica los magnetostermicos y fusibles funcionan esencialmente como elementos de corte y para proteger la instalación en caso de corrientes inversas etc...

    Hay que poner un magneto de 16A por lo menos o en dias de sol puede empezar a saltar, para proteger contra contactos indirectos o bajamos la tensión o ponemos un vigilante de aislamiento.

    lo mismo es más barato cambiar la resistencia del termo por una de 6000W, asi podemos trabajar en torno de los 100-120V, de esta manera poniendo a tierra la mitad de las dos series estaríamos en menos de 60V CC, dentro de la tensión de seguridad que marca el REBT en CC (75V).

    Problema para alimentar termo en CC: reles-termo6000.jpg
    Última edición por Lugh; 28/05/2013 a las 11:15

Página 1 de 3 12 ... ÚltimoÚltimo

Temas similares

  1. [Brico] Existe algun relés programables para desconectar las placas FV de 24
    Por sam33 en el foro Fotovoltaica. Sistemas aislados de la red
    Respuestas: 5
    Último mensaje: 15/04/2019, 10:12
  2. Reles y temporizadores para bombeo solar directo
    Por nostredamus en el foro Fotovoltaica. Sistemas aislados de la red
    Respuestas: 6
    Último mensaje: 28/07/2014, 09:56
  3. Instalación fotovoltaica autónoma para alimentar termo eléctrico
    Por aobradors en el foro Fotovoltaica. Sistemas aislados de la red
    Respuestas: 16
    Último mensaje: 14/11/2012, 00:30
  4. Problema de Calentamiento de Primario con Termo Secundario
    Por jolindrin en el foro Solar térmica
    Respuestas: 3
    Último mensaje: 17/01/2010, 23:08
  5. alimentar termo eléctrico con aerogenerador
    Por jaume65 en el foro Minieólica
    Respuestas: 7
    Último mensaje: 09/03/2009, 22:54

Copyright, 2002-2017 Solarweb.net



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46